Umbau des Datenbank-Bereiches

36 Beiträge · Seite 2 von 2
07.11.2007, 23:25#21
also, wenn ich da auch ein feedback geben darf: ich finde, dass die Bilder bei so brutalem Skalieren zu stark verpixeln!
es sollte eher eine Einstellung "auf 25% skalieren" geben, als fixes "skalieren auf 640 plx".
08.11.2007, 21:18#22
Zitat
Original von heinrich2222
also, wenn ich da auch ein feedback geben darf: ich finde, dass die Bilder bei so brutalem Skalieren zu stark verpixeln!
es sollte eher eine Einstellung "auf 25% skalieren" geben, als fixes "skalieren auf 640 plx".

Wie wär's mit 800x600?
Mann muss halt nur den richtigen Kompromiss zwischen Dateigröße&Upload-dauer und Bildqualität finden.

Edit: Eigentlich ist es gar nicht "fixes Skalieren" auf 640x480, sondern die Breite des Bildes darf höchstens 640 sein, die Höhe höchstens 480. So werden andersformatige Bilder nicht verzerrt.
Dieser Beitrag wurde 1-mal editiert, zuletzt von benkda01 (08.11.2007, 21:20)
08.11.2007, 23:39#23
Zitat
Original von benkda01
Wie wär's mit 800x600?
Mann muss halt nur den richtigen Kompromiss zwischen Dateigröße&Upload-dauer und Bildqualität finden.

Das Problem bei Deinem Bildverkleinerer ist weniger die Bildgröße, denn der Verkleinerungsalgorithmus!

Zitat

Edit: Eigentlich ist es gar nicht "fixes Skalieren" auf 640x480, sondern die Breite des Bildes darf höchstens 640 sein, die Höhe höchstens 480. So werden andersformatige Bilder nicht verzerrt.

Du solltest bei derartigen Angaben immer quadratische Dimensionen benutzen -- es gibt auch Hochformatbilder.
09.11.2007, 19:21#24
Zitat
Original von Linie 41
Zitat
Edit: Eigentlich ist es gar nicht "fixes Skalieren" auf 640x480, sondern die Breite des Bildes darf höchstens 640 sein, die Höhe höchstens 480. So werden andersformatige Bilder nicht verzerrt.

Du solltest bei derartigen Angaben immer quadratische Dimensionen benutzen -- es gibt auch Hochformatbilder.

Ich verstehe dein Anliegen nicht ganz - auch hochformatige Bilder werden nicht verzerrt, sondern auf eine Höhe von 480 Pixeln und eine dazu proportionale Breite verkleinert. ?(
Oder meinst du, dass das zu klein ist? Man könnte die Angaben ja auch manuell eingeben lassen... *programmier* :D
@Algorithmus: Naja, ich kenne mich da leider nicht so aus. Das ist aber laut einer Internetrecherche die einzige VB-Möglichkeit, das durchzuführen...
Alternativ könnte man die Bilder ja auch mit einem Batchkonvertierungsprogramm (z.B. IrfanView) auf dieselbe Größe skalieren, und dann in der (noch folgenden) neuen Version dieselben Höchstmaße einstellen, dann wird gar nichts skaliert.

Mfg, benkda01
12.01.2009, 08:01#25
*Thread entstaub*

Zitat
Original von benkda01
Weiters fände ich es gut, wenn man in seinem eigenen Ordner Unterordner anlegen könnte [...]

Ich spinne den Gedanken ein wenig weiter und wünsche mir, daß man seine eigenen Unterordner auch umbenennen, löschen und mit weiteren Unterordnern versehen könnte, um sowas wie eine übersichtlichere Struktur ins eigene "Refugium" zu bringen. Weiters sollten Dateien nachträglich in andere Unterordner verschoben werden können. (Löschen und Neu-Hochladen ginge zwar auch, allerdings wär' dann die bisherige ID futsch, was diverse Edits in Forenpostings nach sich ziehen würde. :-/ )

Nachtrag 1: Ein Hinweis auf "ungünstige" Sonderzeichen in den Namen der hochzuladenden Dateien wäre auch nicht so verkehrt. In zig Fällen verschwanden mir beispielsweise sämtliche "+"...

Nachtrag 2: Die Sortierung der eigenen Unterordner nach ihrer ID ist auch nicht sooo optimal. Eine dem Alphabet folgende Anordnung wäre nach meinen bisherigen Erfahrungen um Eckhäuser sinnvoller.


Beste Grüße
VT

EDITS: Nachträge ergänzt
Dieser Beitrag wurde 2-mal editiert, zuletzt von VT 5081 (12.01.2009, 08:29)
12.01.2009, 08:33#26
Oh ja da kann ich mich VT 5081 voll und ganz anschliessen. Da ich mir denke dass das auch eine entlastung für den Administrator/Moderator wäre. Und so könnte jeder in "seiner" Datenbank die Bilder nach lust und Laune ordnen. :daumenhoch:
12.01.2009, 10:32#27
Zitat
Original von VT 5081
Nachtrag 1: Ein Hinweis auf "ungünstige" Sonderzeichen in den Namen der hochzuladenden Dateien wäre auch nicht so verkehrt. In zig Fällen verschwanden mir beispielsweise sämtliche "+"...

Naja... um Probleme zu vermeiden, ist es auch heute nicht ganz verkehrt, Dateinamen so zu gestalten, dass sie nur aus A-Z, a-z, 0-9 und _ bestehen. :lampe:
12.01.2009, 16:42#28
Zitat
Original von Paul Posch
Oh ja da kann ich mich VT 5081 voll und ganz anschliessen.

Dem schließe ich mich an! Unterordner wären nicht verkehrt. So wie es jetzt ist, wird es schnell sehr unübersichtlich.
12.01.2009, 18:08#29
und was machn user, die keine computerfuzzis sind??
sowie ich einer bin .....

i hab den office picture manager, sosnt nix........ 8-)
12.01.2009, 18:39#30
Zitat
Original von ustrab
und was machn user, die keine computerfuzzis sind??
sowie ich einer bin .....

i hab den office picture manager, sosnt nix........ 8-)


Meiner Ansicht nach würde diese veränderung nur die "Gästegalerie" betreffen. Sodas jeder eigenständig dort Ordner erstellen kann ohne hierfür den Adminisrator bzw. einen Moderator bemühen muß. Der restliche Datenbankbereich wäre nach wie vor den Administrator/Moderatoren vorbehalten um dort ändreungen vorzunehmen. Ich sehe das ganze auch als eine entlastung vom Administrator und von den Moderatoren.

Edit: Rechtschreibung
Dieser Beitrag wurde 1-mal editiert, zuletzt von Paul Posch (12.01.2009, 18:41)
12.01.2009, 19:45#31
Zitat
Original von 95B
Naja... um Probleme zu vermeiden, ist es auch heute nicht ganz verkehrt, Dateinamen so zu gestalten, dass sie nur aus A-Z, a-z, 0-9 und _ bestehen. :lampe:

Hm... - damit muß ich meine obige Wunschliste um ein Werkzeug erweitern, das den Dateinamen, der beim Wieder-Runterladen "hinten raus kommt", auch manipulieren kann.

Zitat
Original von Paul Posch
Meiner Ansicht nach würde diese veränderung nur die "Gästegalerie" betreffen. Sodas jeder eigenständig dort Ordner erstellen kann ohne hierfür den Adminisrator bzw. einen Moderator bemühen muß.

Ordner kannst Du auch jetzt schon erstellen! (Zwar nur eine Ebene tief, aber immerhin.) Allerdings wirst Du sie nicht mehr los, falls Du ihrer irgendwann überdrüssig werden solltest. Außerdem mußt Du bei ihrer Benennung äußerste Sorgfalt walten lassen, denn Tipp- und sonstige Fehler bleiben bis ans Ende aller Server-Tage erhalten...

Beste Grüße
VT (wohl in Bälde einen "Wunschzettel" mit Lösch- und Korrekturwünschen für das Zeug in "seinem" Datenbank-Areal an die Administration schickend)
13.01.2009, 09:46#32
Zitat
Original von VT 5081
Zitat
Original von 95B
Naja... um Probleme zu vermeiden, ist es auch heute nicht ganz verkehrt, Dateinamen so zu gestalten, dass sie nur aus A-Z, a-z, 0-9 und _ bestehen. :lampe:

Hm... - damit muß ich meine obige Wunschliste um ein Werkzeug erweitern, das den Dateinamen, der beim Wieder-Runterladen "hinten raus kommt", auch manipulieren kann.

Wieso soll das Fanpage-Team die Galerie daran anpassen, dass du keine internetfähigen Dateinamen verwendest? Du solltest die Sache umgekehrt betrachten: Benutze internetfähige Dateinamen und du wirst keine Probleme mit den Sonderzeichen haben. 8-) :lampe:
13.01.2009, 13:24#33
Internetfähige Dazeinamen sind bei einem UTF-8 Dateisystem alle ;)
13.01.2009, 14:38#34
Zitat
Original von 95B
Wieso soll das Fanpage-Team die Galerie daran anpassen, dass du keine internetfähigen Dateinamen verwendest?

Gegenfrage: Wieso hat eben diese meine Nomenklatur auf zwei anderen Servern keine Probleme gemacht und konnte problemlos hochgeladen, verlinkt, etc. werden? :-) (Aber ich seh' grad, daß das Glücksfälle gewesen sein müssen, denn...

Zitat
Du solltest die Sache umgekehrt betrachten: Benutze internetfähige Dateinamen und du wirst keine Probleme mit den Sonderzeichen haben. 8-) :lampe:

...die "Richtlinie", die mir Google zuerst ausgeworfen hat,...

Zitat
RFC-1738; http://tools.ietf.org/html/rfc1738
2.1. The main parts of URLs

[...] The lower case letters "a"--"z", digits, and the characters plus ("+"), period ("."), and hyphen ("-") are allowed.

...ist in dem Punkt von was "Nachgeschossenem" ersetzt worden.

Zitat
RFC-2396; http://www.ietf.org/rfc/rfc2396.txt
G.2. Modifications from both RFC 1738 and RFC 1808

[...] The plus "+", dollar "$", and comma "," characters have been added to those in the "reserved" set, since they are treated as reserved within the query component.

Dann also auf fröhliches kleinweises Dateien-Ersetzen meinerseits, damit am Ende alles seine Richtigkeit hat... ;-)) )

Ach ja, einen Wunsch hätte ich noch: speziell nach einem Multi-Upload wär's schön, wenn die roten Bestätigungsmeldungen einen Link zur jeweiligen Bild-Seite enthielten. Dann müßte man für weitere Anpassungsaktionen keinen Umweg über die Übersicht gehen. :-)

Beste Grüße
VT
13.01.2009, 17:01#35
Ich danke dir, VT 5081 für das Ansprechen dieses Themas und möchte mich ebenfalls deinen Vorschlägen anschließen!

Um es einmal zusammenzufassen - gewünscht wäre:

  • das Umbenennen und Löschen von Underordnern;

  • das Erstellen von anderen Unterordnern "untergeordneten" Unterordnern;

  • eine Möglichkeit zu möglichst "umweglosem" Verschieben von Dateien vom eigenen Ordner in der Gästegalerie in einen der darin befindlichen Unterordner sowie von Unterordner zu Unterordner;

  • eine Möglichkeit eines direkten (Multi)uploads von Dateien in einen Unterordner;

  • das Verlinken der nach einem erfolgreichen Upload angezeigten roten Bestätigungsmeldung(en) mit der jeweiligen Datei-(/Bild-)Seite [wobei dadurch folgendes zumindest für mich recht praktisch wäre: da auf der "Bestätigungsseite" nach jedem Upload ohnehin ja das Hochgeladene angezeigt wird und der von VT 5081 angesprochene und gewünschte Link zur jeweiligen Datei-Seite, wie ich einmal annehme, die Bild-ID enthielte, müsste ich ja gar nicht mehr den Link selbst anklicken, sondern einfach mit der Maus auf diesem "zum Stehen" kommen, und von der Statusleiste meines Web-Browsers die Bild-ID ablesen - hierbei wäre es widerum auch noch erleichternd, wenn bei einem Multi-Upload jede Bestätigungsmeldung erst über/unter dem jeweiligen Bild bzw. der jeweiligen Dateivorschau stünde, da bei der Erstellung von Reportagen und dem Anwenden meiner soeben erwähnten Vorgehensweise zum Herausfinden der Bild-ID deren Zuordnung zum jeweiligen Bild leichter und vor allem übersichtlicher wäre;

  • sowie die Möglichkeit zur Verwendung von diversen Sonderzeichen bei der Benennung der hochzuladenden bzw. hochgeladenen Dateien.


Vorerst einmal war's das von meiner Seite - sollte mir noch etwas einfallen, werde ich dies nachtragen; ich wäre dem Fanpage-Team sehr dankbar, wenn auch nur einer der oben angeführten Vorschläge in die Tat umgesetzt würde! =)
18.05.2009, 10:57#36
Die Datenbank wurde auf die neue Version 1.7.7 upgedatet.

Ich habe eure Anregungen nicht vergessen, nur hatte ich bisher wenig Zeit mich darum zu kümmern. ;)